Getting Shadow to work on Ubuntu 20.04

Getting Shadow to work on Ubuntu 20.04

This morning, I installed Pop!_OS on my laptop, as Elementary OS was starting to have some issues, and I wanted to try something different. The current version of Pop!_OS is based on Ubuntu 20.04. If you are an avid Linux user and a Shadow user, you may know that Shadow on anything other than Ubuntu 18.04 can be a bit temperamental.

Since Elementary OS 5.1 is based on Ubuntu 18.04, I did not run into any issues, other than needing to disable my NVIDIA GPU on my laptop. However, running on the latest Pop!_OS distribution proved to be a bit of an issue.

The latest version of Pop!_OS runs on Ubuntu 20.04, which ended up throwing an L:100 error when I tried to start Shadow. This error made me wonder if it was a graphics card issue. I vaguely remembered this happening when I initially tried to use Shadow on my laptop when it had Windows with the NVIDIA GeForce 940MX enabled.

So, I started to research the issue, and I came across the Shadow on Linux GitHub page. This site is a community of fellow Linux users helping each other to get Shadow working on your Linux distribution.

The Shadow on Linux community has their community projects like the Shadow Live OS, ShadowOS Networked Boot, and Shadowcker, but they also have installation instructions to get you up and running with Shadow on Linux.

This community is where I came across the fix to get Shadow working on Pop!_OS.

Getting Shadow to work on Pop!_OS (Ubuntu)

You see, Shadow uses the VA-API on Linux to stream your Shadow PC to your computer. If your GPU does not support the VA-API or is not correctly configured, you will run into issues.

Since I actively disable the NVIDIA GPU on my laptop, I know the issue was related to the integrated Intel GPU on my laptop. Thanks to the setup instructions on Shadow on Linux, I found out that I needed to install the proper Intel GPU drivers via sudo apt install intel-media-va-driver-non-free.

Now, if this command doesn't work for you, you are probably using an older generation of Intel that requires a different driver. You can try using sudo apt install i965-va-driver.

One of the two above commands should work, and after you have it installed, you should be able to launch your Shadow without any errors! If you installed the drivers above, and still run into issues, feel free to comment below or reach out to the Shadow on Linux community for help!

On a quick note, I highly recommend disabling your NVIDIA GPU when attempting to use Shadow. If you want or require your GPU when using Shadow on Linux, try using a distribution that allows hybrid mode and force the Shadow client to utilize your integrated Intel GPU. You will have fewer issues and decreased power consumption!


Do you use Shadow on Linux? What distribution do you use?

Follow Luro.io on Twitter

Sign up for Shadow using the referral code "luroio" or by clicking this link to get up to $15 off your first month!

Comments

Sign in or become a Luro.io member to join the conversation.
Just enter your email below to get a log in link.

You've successfully subscribed to Luro.io
Great! Next, complete checkout for full access to Luro.io
Welcome back! You've successfully signed in.
Success! Your account is fully activated, you now have access to all content.
Success! Your billing info is updated.
Billing info update failed.